Aggiornare a Rubygems 1.36

Se dovete avere a che fare col sistema di pacchettizzazione multipiattaforma "gem" vi sconsiglio caldamente di usare il pacchetto "rubygems" per Debian/Ubuntu, oltre ad essere (inevitabilmente) indietro non potete autoaggiornarlo.
UPDATE: se non volete avere problemi usate ruby 1.8.7 o 1.9.1.378-1
UPDATE2: se avete ancora Timeout o Gem::RemoteFetcher::FetchError applicate questa patch. Tnx raggi su #rubygems

$ sudo gem update --system

Updating RubyGems
Updating rubygems-update
Successfully installed rubygems-update-1.3.6
Updating RubyGems to 1.3.6
Installing RubyGems 1.3.6
/usr/lib/ruby1.9/gems/1.9.0/gems/gemcutter-0.5.0/lib/gemcutter.rb:4:in `require': no such file to load -- rubygems/commands/migrate (LoadError)
from /usr/lib/ruby1.9/gems/1.9.0/gems/gemcutter-0.5.0/lib/gemcutter.rb:4:in `block in <top (required)>' ...

Come mantenerlo aggiornato
$ sudo -s
# gem update --system
Updating RubyGems
Updating rubygems-update
Successfully installed rubygems-update-1.3.6
Updating RubyGems to 1.3.6
Installing RubyGems 1.3.6
RubyGems 1.3.6 installed
=== 1.3.6 / 2010-02-17
NOTE:
http://rubygems.org is now the default source for downloading gems.
You may have sources set via ~/.gemrc, so you should replace
http://gems.rubyforge.org will continue to work for the forseeable future.
New features:
* `gem` commands
  * Added `gem push` and `gem owner` for interacting with modern/Gemcutter
    sources
  * `gem dep` now supports --prerelease.
  * `gem fetch` now supports --prerelease.
  * `gem server` now supports --bind.  Patch #27357 by Bruno Michel.
  * `gem rdoc` no longer overwrites built documentation.  Use --overwrite
    force rebuilding.  Patch #25982 by Akinori MUSHA.
* Captial letters are now allowed in prerelease versions.

 

corso javascript